Descubren una vulnerabilidad que afecta a Java en escritorio y servidor

CloudSeguridad

El experto Adam Godwiak ha vuelto a encontrar un fallo de seguridad que permite a ciberdelincuentes potenciales saltarse el sandbox del lenguaje de Oracle.

Malas noticias para Java. El experto en seguridad, y también experto en encontrar vulnerabilidades en el software de Oracle, Adam Gowdiak, acaba de detectar un nuevo fallo.

Dicho fallo afecta a “todas las versiones de Java SE 7”, incluyendo el software JDK, JRE Plugin y la reciente versión de escritorio 1.7.0_21-b11, además de la edición para servidor JRE 7. Y, al parecer, se encuentra presente en la API Reflection permitiendo a los atacantes saltarse el sandbox de este lenguaje para acabar accediendo al sistema subyacente.

Gowdiak no ha querido publicar más detalles sobre el problema para evitar que los ciberdelincuentes se aprovechen de él y darle tiempo suficiente a Oracle a que encuentre una solución efectiva.

Para explotar este bug con éxito a través de los distintos navegadores web se necesitaría una interacción explícita del usuario, de tal modo que éste aceptase el riesgo de ejecutar una aplicación potencialmente maliciosa, tal y como advierten los cuadros de diálogo implementados por la compañía de Redwood Shores la semana pasada.

Eso sí, este nuevo descubrimiento significa que en estos momentos hay tres vulnerabilidades descubiertas por este mismo investigador que todavía requieren de correcciones: los problemas 54, 56 y 61, según la numeración que les ha otorgado.

Leer la biografía del autor  Ocultar la biografía del autor